Skip to main content
CVE-2026-118752VulnerabilityPublished

FreeImage (danoli3 fork) before 3.19.22 contains a heap buffer overflow vulnerability in the PBM RLE decoder of

Affects FreeImageSource GCVE Database

0
Authoritative record:CVE-2026-118752· High 8.5

Not known to be exploited · CVSS 8.5 High : upgrade to 3.19.22 soon.

Data as of 29 Oct 2026, 01:14 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.19.22
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade danoli3/FreeImage to 3.19.22.

Affected software

ProductAffectedFixed in
GitHubdanoli3/FreeImagepkg:github/danoli3/FreeImageOther threatsAffected
  • <3.19.22
Fixed in
  • 3.19.22

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in FreeImage version 3.19.22 and later. Users should upgrade to version 3.19.22 or newer to remediate this vulnerability. No alternative mitigations or workarounds are indicated in the available data.

Description

FreeImage (danoli3 fork) versions before 3.19.22 contain a heap buffer overflow vulnerability in the PBM RLE decoder within PluginIFF.cpp. The flaw arises due to missing bounds checks on ByteRun1 runs, allowing crafted IFF/LBM PBM files with runs crossing scanline boundaries to write up to 127 bytes beyond the allocated heap buffer. This vulnerability has a high severity rating with a CVSS score of 7.8.

References

Community reviews

Loading reviews…