Skip to main content
CVE-2026-110835VulnerabilityPublished Updated

FreeRDP 3.0.0 before 3.32.0 allows HTTP header injection in its proxy because a lone LF in the target portion of a

Affects freerdpSource GCVE Database

0

Not known to be exploited · CVSS 5.8 Medium · fixed in 3.32.0+dfsg-0ubuntu0.24.04.1 : update freerdp when convenient.

Data as of 27 Oct 2026, 08:12 UTC

CVSS 3.1 base score
5.8Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.32.0+dfsg-0ubuntu0.24.04.1, 3.32.0+dfsg-0ubuntu0.26.04.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu freerdp3 to 3.32.0+dfsg-0ubuntu0.24.04.1 (package) or 3.32.0+dfsg-0ubuntu0.26.04.1 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=resoluteOther threatsAffected
  • <3.32.0+dfsg-0ubuntu0.26.04.1
Fixed in
  • 3.32.0+dfsg-0ubuntu0.26.04.1
Ubuntu 24.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=nobleOther threatsAffected
  • <3.32.0+dfsg-0ubuntu0.24.04.1
Fixed in
  • 3.32.0+dfsg-0ubuntu0.24.04.1
Ubuntu Pro 24.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 2.10.0+dfsg1-1.1ubuntu1 – 2.11.5+dfsg1-1ubuntu0.1~esm6
12 affected builds
Fixed in–
Ubuntu 22.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=jammyOther threatsAffected
  • 2.3.0+dfsg1-2build1 – 2.6.1+dfsg1-3ubuntu2.11
23 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/focalOther threatsAffected
  • 2.0.0~git20190204.1.2693389a+dfsg1-1 – 2.6.1+dfsg1-0ubuntu0.20.04.2+esm4
17 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 2.0.0~git20170725.1.1648deb+dfsg1-1 – 2.2.0+dfsg1-0ubuntu0.18.04.4+esm6
19 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied. Fixed versions include 3.32.0+dfsg-0ubuntu0.24.04.1 and 3.32.0+dfsg-0ubuntu0.26.04.1. Upgrading to these versions or later will remediate the vulnerability.

Description

FreeRDP versions before 3.32.0 contain an HTTP header injection vulnerability in its proxy component. This occurs because a lone line feed (LF) character in the target portion of a routing token (Cookie: msts=) is not properly rejected. An unauthenticated remote RDP client connecting to a proxy with FixedTarget=false and an upstream HTTP proxy can manipulate HTTP request and header framing at the upstream proxy.

References

Community reviews

Loading reviews…