CVE-2026-114046: (FreeRDP 3.0.0 before 3.32.0 contains a null-pointer dereference in the ...)
Affects freerdpSource GCVE Database
Not known to be exploited · CVSS 7.1 High · fixed in 3.32.0 : patch freerdp soon.
Data as of 27 Oct 2026, 07:12 UTC
- Patch
- Available – fixed in 3.32.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10freerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu Pro 24.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in FreeRDP version 3.32.0 and later. Users should upgrade to version 3.32.0 or newer to remediate this vulnerability. Since the affected versions are specific Ubuntu package builds, applying the corresponding updated packages from Ubuntu security repositories is recommended.
Description
FreeRDP versions before 3.32.0 contain a null-pointer dereference vulnerability that can cause a denial of service. The flaw affects multiple Ubuntu package versions of FreeRDP. The vulnerability has a CVSS 3.1 base score of 6.5, indicating medium severity, with no confidentiality or integrity impact but potential availability impact.