FreeRDP before 3.32.2 contains a denial of service vulnerability where rdg_process_packet dispatches a
Source GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.32.2 when convenient.
Data as of 3 Nov 2026, 16:43 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 5.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 4.3 |
- Patch
- Available – fixed in 3.32.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade FreeRDP to 3.32.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FreeRDPFreeRDP | Affected
| Fixed in
|
AI-suggested
Upgrade FreeRDP to version 3.32.2 or later, where this vulnerability is fixed. No other mitigations are specified.
Description
FreeRDP versions prior to 3.32.2 have a denial of service vulnerability due to improper handling of extended authentication packets. Specifically, the rdg_process_packet function dispatches a PKT_TYPE_EXTENDED_AUTH_MSG without verifying the negotiated mode or authentication context. This allows a malicious or compromised Remote Desktop Gateway to send an extended-auth packet before tunnel authentication, causing a null-pointer dereference that crashes the client application.