FreeRDP from 3.0.0 before 3.32.2 contains a denial of service vulnerability that allows malicious RDP servers to abort
Source GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 3.32.2 soon.
Data as of 3 Nov 2026, 16:43 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.1 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 6.5 |
- Patch
- Available – fixed in 3.32.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade FreeRDP to 3.32.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FreeRDPFreeRDP | Affected
| Fixed in
|
AI-suggested
A fix is available in FreeRDP version 3.32.2. Users should upgrade to version 3.32.2 or later to remediate this vulnerability. Until patched, users can consider disabling verbose WinPR assertions to reduce exposure, though this may limit debugging capabilities.
Description
FreeRDP versions from 3.0.0 up to but not including 3.32.2 contain a denial of service vulnerability. This flaw allows malicious RDP servers to crash clients built with verbose WinPR assertions by sending specially crafted RemoteFX region rectangles. The vulnerability triggers a 16-bit coordinate assertion failure in the rfx_process_message function, causing the client process to terminate unexpectedly.