CVE-2024-32874: Frigate · Malicious Long Unicode filenames may cause a Multiple Application-level Denial of Service
Affects frigateSource GCVE Database
Not known to be exploited · CVSS 9.3 Critical : upgrade to 0.13.2 as a priority.
Data as of 27 Oct 2026, 17:29 UTC
- Patch
- Available – fixed in 0.13.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:HExploitation evidence
Disclosed: evidence found.
CVE published 9 May 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade frigate to 0.13.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIfrigate | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Frigate version 0.13.2 that addresses this vulnerability. Users should upgrade to version 0.13.2 or later. Additionally, ensure that authentication is configured in front of the Frigate instance (e.g., via a reverse proxy) to prevent unauthorized access, as exploitation requires access to the instance. Do not expose the Frigate instance publicly without authentication.
Description
CVE-2024-32874 is a critical application-level denial of service vulnerability in Frigate versions prior to 0.13.2. It arises when an attacker with access to the Frigate instance uploads or uses extremely long Unicode filenames, which trigger costly Unicode normalization operations in the secure_filename() function. This can exhaust CPU resources and cause the application to become unresponsive. Exploitation requires attacker access to the Frigate instance, and proper authentication can prevent exploitation. A fix is available in version 0.13.2.
References
- github.com/blakeblackshear/frigate/security/advisories/GHSA-w4h6-9wrp-v5jq (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2024-32874 (opens in a new tab)
- github.com/blakeblackshear/frigate/commit/cc851555e4029647986dccc8b8ecf54afee31442 (opens in a new tab)
- github.com/blakeblackshear/frigate (opens in a new tab)
- github.com/blakeblackshear/frigate/blob/d7ae0eedf89e14f297093ac5c8042862034cbaeb/frigate/api/media.py (opens in a new tab)
- github.com/blakeblackshear/frigate/blob/d7ae0eedf89e14f297093ac5c8042862034cbaeb/frigate/api/media.py (opens in a new tab)
- github.com/blakeblackshear/frigate/blob/d7ae0eedf89e14f297093ac5c8042862034cbaeb/frigate/api/media.py (opens in a new tab)
- github.com/blakeblackshear/frigate/blob/d7ae0eedf89e14f297093ac5c8042862034cbaeb/frigate/api/media.py (opens in a new tab)
- github.com/blakeblackshear/frigate/blob/d7ae0eedf89e14f297093ac5c8042862034cbaeb/frigate/api/media.py (opens in a new tab)
- github.com/blakeblackshear/frigate/blob/d7ae0eedf89e14f297093ac5c8042862034cbaeb/frigate/api/media.py (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/frigate/PYSEC-2026-342.yaml (opens in a new tab)
- pypi.org/project/frigate (opens in a new tab)