Skip to main content
VulnerabilityPublished Updated

CVE-2026-5107: frr vulnerability

Affects frrSource GCVE Database

0
Authoritative record:CVE-2026-5107· Low 2.3

Not known to be exploited · CVSS 2.3 Low · fixed in 7.2.1-1ubuntu0.2+esm4 : update frr when convenient.

Data as of 27 Oct 2026, 01:12 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 7.2.1-1ubuntu0.2+esm4, 8.1-1ubuntu1.15, 8.4.4-1.1ubuntu6.6 +1
CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/E:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10frrpkg:deb/ubuntu/frr?arch=source&distro=questingOther threatsAffected
  • <10.4.1-3ubuntu1.2
Fixed in
  • 10.4.1-3ubuntu1.2
Ubuntu 24.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=nobleOther threatsAffected
  • <8.4.4-1.1ubuntu6.6
Fixed in
  • 8.4.4-1.1ubuntu6.6
Ubuntu 22.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=jammyOther threatsAffected
  • <8.1-1ubuntu1.15
Fixed in
  • 8.1-1ubuntu1.15
Ubuntu Pro 20.04 LTSfrrpkg:deb/ubuntu/frr?arch=source&distro=esm-apps/focalOther threatsAffected
  • <7.2.1-1ubuntu0.2+esm4
Fixed in
  • 7.2.1-1ubuntu0.2+esm4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and users should update their FRR packages to the fixed versions listed in the Ubuntu security advisory USN-8175-1. Standard system updates will apply the necessary patches. Ubuntu Pro users receive extended security coverage via ESM. No additional mitigation actions are indicated by the vendor advisory.

Description

A vulnerability in FRR was discovered where it did not correctly handle certain network requests, potentially allowing a remote attacker to gain unauthorized access to resources. This issue affects multiple Ubuntu package versions of FRR. Fixed versions are available and users are advised to update to these versions to mitigate the risk.

References

Community reviews

Loading reviews…