CVE-2024-5435: Generation of Error Message Containing Sensitive Information in GitLab
Affects gitlabSource GCVE Database
Not known to be exploited · fixed in 17.3.2 : update gitlab when convenient.
Data as of 26 Oct 2026, 17:16 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.3.2, 17.2.5, 17.1.7
Exploitation evidence
Disclosed: evidence found.
CVE published 14 Sep 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 17.3.2, 17.2.5 or 17.1.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade GitLab to versions 17.1.7 or later, 17.2.5 or later, or 17.3.2 or later as appropriate to their current version. Applying these updates will remediate the sensitive information disclosure issue.
Description
A vulnerability in GitLab EE/CE versions from 15.10 up to but not including 17.1.7, from 17.2 up to but not including 17.2.5, and from 17.3 up to but not including 17.3.2 allows disclosure of user passwords from repository mirror configuration through error messages.