CVE-2026-42931: Gitea · Denial of Service via Unbounded io.ReadAll in NPM Package Tag Endpoint
Affects code.gitea.io/giteaSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.27.0 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.27.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CISA SSVC: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by Gitea Limited
, 36 days before disclosure
CVE published
on cve.org
, t = 0
CISA SSVC assessment
proof of concept public
, 3 hours after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade code.gitea.io/gitea to 1.27.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Gocode.gitea.io/gitea | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available to remediate this vulnerability. Users should upgrade Gitea to version 1.27.0 or later to mitigate the risk. Since no vendor advisory explicitly states otherwise, applying the official fix is the recommended mitigation. No additional mitigations are specified.
Description
Gitea versions prior to 1.27.0 contain a denial of service vulnerability in the NPM package tag API endpoint. The issue arises from an unbounded io.ReadAll call that reads the entire HTTP request body into memory without size limits. Authenticated users with write access to their package namespace can exploit this by sending a large request, causing the server process to crash due to out-of-memory conditions. This crash results in a persistent denial of service that can survive automatic restarts. The vulnerability has a moderate severity with a CVSS score of 6.5. A patch is available to address this issue.