CVE-2026-14341: GitLab Has Remediated an Issue
Affects gitlabSource GCVE Database
Not known to be exploited · CVSS 4.9 Medium · fixed in 19.2.1 : update gitlab when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 19.2.1, 19.1.3, 19.0.5
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade gitlab to 19.2.1, 19.1.3 or 19.0.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
RubyGemsgitlabpkg:gem/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
GitLab has released official fixes for this vulnerability in versions 19.0.5, 19.1.3, and 19.2.1. Users should upgrade affected GitLab CE/EE instances to these or later versions to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.
Description
A vulnerability in GitLab CE/EE versions from 12.8 before 19.0.5, 19.1 before 19.1.3, and 19.2 before 19.2.1 allows an authenticated user with Maintainer role to modify protected branch configurations due to improper authorization in a project API endpoint. This issue has been remediated by GitLab in the specified fixed versions.