Skip to main content
CVE-2026-6896VulnerabilityPublished

GitLab EE affecting all · GitLab Has Remediated an Issue

Affects gitlabSource GCVE Database

0

Not known to be exploited · CVSS 8.7 High · fixed in 18.11.7 : patch gitlab soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.11.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 16.04 LTSgitlabpkg:deb/ubuntu/gitlab@8.5.8+dfsg-5?arch=source&distro=xenialOther threatsAffected
  • =8.4.3+dfsg-9
  • =8.4.3+dfsg-12
  • =8.5.8+dfsg-5
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in GitLab EE versions 18.11.7, 19.0.4, and 19.1.2 and later. Users should upgrade to these or later versions to remediate the vulnerability. For affected Ubuntu packages, users should apply the corresponding package updates. No information indicates that the vulnerability is mitigated by other means.

Description

CVE-2026-6896 is a vulnerability in GitLab EE that affects versions from 13.11 before 18.11.7, 19.0 before 19.0.4, and 19.1 before 19.1.2, as well as certain Ubuntu package versions. It allows an authenticated user with developer-role permissions to execute arbitrary scripts in another user's browser session due to improper sanitization of user input. The vulnerability impacts confidentiality and integrity but does not affect availability.

References

Community reviews

Loading reviews…