Skip to main content
CVE-2026-73624VulnerabilityPublished Updated

mistral-vibe · GitPython: Arbitrary file overwrite via git diff --output argument injection in Diffable.diff (key- and

Affects mistral-vibeSource GCVE Database

0
Compare
Authoritative record:CVE-2026-73624· High 7.2

Not known to be exploited · CVSS 7.2 High : upgrade to 2.24.0 soon.

Data as of 30 Oct 2026, 07:45 UTC

CVSS 4.0 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.24.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade mistral-vibe to 2.24.0.

Affected software

ProductAffectedFixed in
Homebrewmistral-vibepkg:brew/mistral-vibeOther threatsAffected
  • >=2.1.0 <2.24.0
Fixed in
  • 2.24.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in GitPython version 2.24.0 that adds validation to Diffable.diff() to check for unsafe options and prevents the 'other' argument from being interpreted as a git option by placing a '--end-of-options' marker before it. Users should upgrade to version 2.24.0 or later to remediate this vulnerability. No additional mitigation is required if the patch is applied.

Description

GitPython's Diffable.diff() method allows attacker-controlled arguments to be passed directly to git diff commands without proper validation. This enables an attacker to use the --output option to overwrite arbitrary files with diff content at the privilege level of the process. The vulnerability affects versions prior to 2.24.0 and was confirmed on version 3.1.53. A fix is available in version 2.24.0 that adds validation to prevent unsafe options.

References

Community reviews

Loading reviews…