Skip to main content
VulnerabilityPublished Updated

CVE-2026-67325: GitPython · Command Injection via git long-option prefix abbreviation bypass of CVE-2026-42215 blocklist

Affects fdroidserverSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-67325· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 2.4.5_1 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.2% chance of exploitation in 30 days – higher than 82% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.5_1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 1 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by VulnCheck

    , 3 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 4 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade fdroidserver to 2.4.5_1.

Affected software

ProductAffectedFixed in
Homebrewfdroidserverpkg:brew/fdroidserverOther threatsAffected
  • >=0.7.0 <2.4.5_1
Fixed in
  • 2.4.5_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in GitPython version 2.4.5_1 that addresses this incomplete fix by properly handling git's long-option prefix abbreviations in the unsafe options blocklist. Users should upgrade to version 2.4.5_1 or later. Until patched, avoid passing untrusted or attacker-controlled keyword argument keys to GitPython methods that invoke git commands with allow_unsafe_options set to False. The vulnerability is in the defense-in-depth control and requires specific usage patterns to be exploitable.

Description

GitPython versions from 0.7.0 up to but not including 2.4.5_1 contain a command injection vulnerability due to incomplete blocking of unsafe git options. The fix for CVE-2026-42215 implemented in version 3.1.47 blocks dangerous git options by exact matching after normalizing underscores to hyphens, but does not account for git's acceptance of unambiguous long-option prefix abbreviations. This allows attackers controlling keyword argument keys to bypass the blocklist and execute arbitrary commands via git clone, fetch, pull, or push operations. The vulnerability is exploitable when attacker-controlled keys are passed to GitPython calls with unsafe options disallowed (allow_unsafe_options=False). A patch is available in version 2.4.5_1.

References

Community reviews

Loading reviews…