mistral-vibe · GitPython: command injection via unguarded Git options in `Repo.archive()`, `git.ls_remote()`, and arbitrary file
Affects mistral-vibeSource GCVE Database
Not known to be exploited · CVSS 8.6 High : upgrade to 2.21.0 soon.
Data as of 30 Oct 2026, 08:01 UTC
- Patch
- Available – fixed in 2.21.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mistral-vibe to 2.21.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmistral-vibepkg:brew/mistral-vibeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in GitPython version 2.21.0 that addresses these command injection vulnerabilities. Users should upgrade to version 2.21.0 or later to remediate the issue. Until upgraded, avoid passing untrusted input as options or revision strings to GitPython methods such as Repo.archive(), git.ls_remote(), Repo.iter_commits, and Repo.blame.
Description
GitPython versions from 2.1.0 up to but not including 2.21.0 contain command injection vulnerabilities via unguarded Git options in methods such as Repo.archive(), git.ls_remote(), and others. These flaws allow an attacker to execute arbitrary commands or cause file truncation by injecting malicious options or revision strings. The issue arises because certain GitPython methods do not properly validate or restrict user-supplied arguments that are passed directly to Git commands. A fix is available in version 2.21.0.
References
- github.com/gitpython-developers/GitPython/security/advisories/GHSA-956x-8gvw-wg5v (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-67323 (opens in a new tab)
- github.com/gitpython-developers/GitPython/pull/2163 (opens in a new tab)
- github.com/gitpython-developers/GitPython/commit/701ce32fe5ba8cb622c0e0342a376a6beb47d738 (opens in a new tab)
- github.com/gitpython-developers/GitPython (opens in a new tab)
- github.com/gitpython-developers/GitPython/releases/tag/3.1.51 (opens in a new tab)
- vulncheck.com/advisories/gitpython-before-command-injection-via-unguarded-git-options (opens in a new tab)