Skip to main content
VulnerabilityPublished Updated

CVE-2026-78676: GitPython · Dormant multi-line git-config values are corrupted into live injected directives (e.g

Affects snakemakeSource GCVE Database

0
Authoritative record:CVE-2026-78676· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical : upgrade to 9.25.2 as a priority.

Data as of 26 Oct 2026, 19:26 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 9.25.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade snakemake to 9.25.2.

Affected software

ProductAffectedFixed in
Homebrewsnakemakepkg:brew/snakemakeOther threatsAffected
  • >=5.5.3 <9.25.2
Fixed in
  • 9.25.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in snakemake version 9.25.2. Users should upgrade to this version or later to remediate the vulnerability. The vendor has implemented proper serialization logic to prevent multi-line config values from being corrupted into injected directives. Until upgrading, avoid using GitPython-based tools to write to git config files that may contain untrusted multi-line values.

Description

CVE-2026-78676 is a critical vulnerability in GitPython's GitConfigParser affecting multi-line git-config values. The issue arises because multi-line values read from disk are re-serialized incorrectly, causing dormant config lines to be interpreted as active injected directives. This can lead to arbitrary code execution via the core.hooksPath configuration, which controls Git hook execution paths. The vulnerability affects GitPython versions from 5.5.3 up to but not including 9.25.2 and is fixed in version 9.25.2.

References

Community reviews

Loading reviews…