CVE-2026-78676: GitPython · Dormant multi-line git-config values are corrupted into live injected directives (e.g
Affects mistral-vibeSource GCVE Database
Not known to be exploited · CVSS 9.3 Critical : upgrade to 2.26.0 as a priority.
Data as of 30 Oct 2026, 07:44 UTC
- Patch
- Available – fixed in 2.26.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mistral-vibe to 2.26.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmistral-vibepkg:brew/mistral-vibeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in GitPython version 2.26.0. Users should upgrade to this version or later to prevent exploitation. The vulnerability arises from GitPython's internal re-serialization logic and cannot be mitigated by configuration changes alone. Applying the official patch is the recommended remediation.
Description
CVE-2026-78676 is a critical vulnerability in GitPython's GitConfigParser affecting multi-line git-config values. The issue arises from improper re-serialization of multi-line config values read from disk, causing dormant values to be corrupted into live injected directives. This can lead to arbitrary code execution via the core.hooksPath configuration, which is honored by git hook operations. The vulnerability affects GitPython versions from 2.1.0 up to but not including 2.26.0 and is fixed in version 2.26.0.
References
- github.com/gitpython-developers/GitPython/security/advisories/GHSA-284h-m62q-gf8w (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-78676 (opens in a new tab)
- github.com/gitpython-developers/GitPython (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/gitpython/PYSEC-2026-3786.yaml (opens in a new tab)
- vulncheck.com/advisories/gitpython-before-remote-code-execution-via-config-injection (opens in a new tab)