Skip to main content
CVE-2026-76221VulnerabilityPublished Updated

nbdime · GitPython: git-config OPTION-name injection via =/#/whitespace bypasses name validator, enabling forged

Affects nbdimeSource GCVE Database

0
Authoritative record:CVE-2026-76221· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 4.0.4_7 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.4_7
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade nbdime to 4.0.4_7.

Affected software

ProductAffectedFixed in
Homebrewnbdimepkg:brew/nbdimeOther threatsAffected
  • >=1.1.0 <4.0.4_7
Fixed in
  • 4.0.4_7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in GitPython version 4.0.4_7. Users should upgrade to this version or later to mitigate the vulnerability. The fix applies the same strict validation checks to option names as are applied to section names, rejecting unsafe characters such as '=', '#', ';', '[', ']', and whitespace. No additional mitigation steps are required if the upgrade is applied.

Description

GitPython versions up to 3.1.57 contain a vulnerability in the config-name validator that allows injection of arbitrary git configuration directives via crafted option names. The validator fails to reject characters such as '=', '#', ';', '[', ']', and whitespace in option names, enabling attackers to forge config directives like core.sshCommand or core.hooksPath. This can lead to remote code execution on subsequent git operations that use these config values. The issue arises because the safety checks applied to section names are not applied to option names. A fix is available in version 4.0.4_7.

References

Community reviews

Loading reviews…