Skip to main content
CVE-2026-67326VulnerabilityPublished Updated

mistral-vibe · GitPython: Newline injection

Affects mistral-vibeSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-67326· High 7.3

Not known to be exploited · CVSS 7.3 High : upgrade to 2.18.0 or 2.9.5 soon.

Data as of 30 Oct 2026, 08:01 UTC

CVSS 4.0 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.18.0, 2.9.5
CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade mistral-vibe to 2.18.0 or 2.9.5.

Affected software

ProductAffectedFixed in
Homebrewmistral-vibepkg:brew/mistral-vibeOther threatsAffected
  • >=2.1.0 <2.9.5
  • >=2.10.0 <2.18.0
Fixed in
  • 2.9.5
  • 2.18.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading to versions 2.9.5 or 2.18.0 or later. Users should update their GitPython or mistral-vibe installations to these fixed versions to prevent exploitation. No additional mitigations are indicated by the vendor advisory.

Description

A vulnerability in GitPython's config_writer() allows newline injection in the section parameter, bypassing the patch for CVE-2026-42215. This enables an attacker to inject arbitrary section headers into the .git/config file, including a forged [core] section with hooksPath pointing to an attacker-controlled directory. This leads to remote code execution (RCE) when any git hook is triggered. The issue affects versions >=2.1.0 <2.9.5 and >=2.10.0 <2.18.0 and is fixed in versions 2.9.5 and 2.18.0.

References

Community reviews

Loading reviews…