Skip to main content
VulnerabilityPublished Updated

CVE-2026-44244: GitPython · Newline injection in config_writer().set_value() enables RCE via core.hooksPath

Affects mistral-vibeSource GCVE Database

0
Compare
Authoritative record:CVE-2026-44244· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 2.18.0 or 2.9.2 soon.

Data as of 30 Oct 2026, 08:03 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.18.0, 2.9.2
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade mistral-vibe to 2.18.0 or 2.9.2.

Affected software

ProductAffectedFixed in
Homebrewmistral-vibepkg:brew/mistral-vibeOther threatsAffected
  • >=2.1.0 <2.9.2
  • >=2.10.0 <2.18.0
Fixed in
  • 2.9.2
  • 2.18.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in GitPython versions 2.9.2 and 2.18.0. Users should upgrade to these or later versions to remediate the vulnerability. The recommended remediation is for set_value() to reject values containing carriage return, line feed, or NUL characters by raising an exception rather than silently passing or stripping them. This prevents injection of malicious configuration. Applications using GitPython should audit all calls to config_writer().set_value() that accept external input and ensure inputs are sanitized or the library is updated.

Description

GitPython versions >=2.1.0 <2.9.2 and >=2.10.0 <2.18.0 contain a vulnerability in config_writer().set_value() that allows newline injection. This enables an attacker to inject a malicious core.hooksPath configuration, causing Git to execute attacker-controlled hooks during operations like commit, merge, or checkout. The flaw arises because set_value() does not validate or reject newline characters in values, and Git accepts indented [core] stanzas as valid configuration sections. This can lead to persistent repository config poisoning and remote code execution in multi-user or shared environments.

References

Community reviews

Loading reviews…