Skip to main content
VulnerabilityPublished Updated

CVE-2026-30922: Glances · Denial of Service in pyasn1 via Unbounded Recursion

Affects glancesSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High · fixed in 4.5.2_1 : patch glances soon.

Data as of 1 Nov 2026, 01:38 UTC

CVSS 3.0 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.5.2_1, 4.3.3_1, 3.1.6.2
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade glances to 4.5.2_1, 4.3.3_1 or 3.1.6.2.

Affected software

ProductAffectedFixed in
Homebrewglancespkg:brew/glancesOther threatsAffected
  • >=3.0.2_1 <3.1.6.2
  • >=4.3.1_1 <4.3.3_1
  • >=4.5.0.1 <4.5.2_1
Fixed in
  • 3.1.6.2
  • 4.3.3_1
  • 4.5.2_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied. Fixed versions include 3.1.6.2, 4.3.3_1, and 4.5.2_1 of Glances. Users should upgrade to these or later versions to remediate the vulnerability. No other mitigation or workaround is indicated in the vendor advisory.

Description

The pyasn1 library used in Glances is vulnerable to a Denial of Service (DoS) attack due to unbounded recursion when decoding ASN.1 data with deeply nested indefinite-length SEQUENCE or SET tags. An attacker can craft a small payload that causes the decoder to recursively call itself until the Python interpreter crashes with a RecursionError or exhausts system memory, crashing the host application. This affects multiple versions of Glances prior to fixed releases. The vulnerability allows remote attackers to crash services parsing untrusted ASN.1 data, resulting in service disruption.

References

Community reviews

Loading reviews…