CVE-2025-43859: Glances · h11 accepts some malformed Chunked-Encoding bodies
Affects glancesSource GCVE Database
Not known to be exploited · CVSS 9.1 Critical : upgrade to 4.3.1_2 as a priority.
Data as of 30 Oct 2026, 09:00 UTC
- Patch
- Available – fixed in 4.3.1_2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade glances to 4.3.1_2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewglancespkg:brew/glancesOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in h11 version 0.15.0, which corrects the chunked encoding parsing to strictly validate trailing '\r\n' bytes. Glances users should upgrade to version 4.3.1_2 or later, which includes the fixed h11 version. Since exploitation requires both a vulnerable h11 and a buggy proxy, fixing either component mitigates the issue. No additional workarounds are necessary if patching is applied.
Description
A vulnerability in h11's handling of HTTP/1.1 chunked transfer encoding allows malformed chunked bodies with incorrect trailing bytes to be accepted. This leniency can cause request smuggling when combined with a buggy proxy that parses chunked bodies differently, potentially enabling attackers to bypass security controls or steal session credentials. The issue is fixed in h11 version 0.15.0 and affects glances versions >=4.2.1 and <4.3.1_2.
References
- github.com/python-hyper/h11/security/advisories/GHSA-vqfr-h8mv-ghfj (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-43859 (opens in a new tab)
- github.com/python-hyper/h11/commit/114803a29ce50116dc47951c690ad4892b1a36ed (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/h11/PYSEC-2026-348.yaml (opens in a new tab)
- github.com/python-hyper/h11 (opens in a new tab)
- pypi.org/project/h11 (opens in a new tab)