Glances: Starlette vulnerable to O(n^2) DoS via Range header merging in ``starlette.responses.FileResponse``
Affects glancesSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 4.3.3_2 soon.
Data as of 1 Nov 2026, 01:38 UTC
- Patch
- Available – fixed in 4.3.3_2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade glances to 4.3.3_2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewglancespkg:brew/glancesOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Starlette version 4.3.3_2 that fixes the vulnerability. Users should upgrade to version 4.3.3_2 or later to remediate this issue. No additional mitigation actions are required if the patch is applied.
Description
Starlette's FileResponse component contains a vulnerability in its HTTP Range header parsing and merging logic that leads to quadratic-time complexity. An unauthenticated attacker can craft a Range header with many small, disjoint ranges to cause excessive CPU consumption per request, resulting in denial-of-service (DoS) conditions for endpoints serving files. This affects any Starlette application using FileResponse or StaticFiles, including frameworks built on Starlette such as FastAPI. The vulnerability is identified as CVE-2025-62727 and has a CVSS score of 7.5 (high severity). A fix is available in Starlette version 4.3.3_2.
References
- github.com/Kludex/starlette/security/advisories/GHSA-7f5h-v6xp-fcq8 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-62727 (opens in a new tab)
- github.com/Kludex/starlette/commit/4ea6e22b489ec388d6004cfbca52dd5b147127c5 (opens in a new tab)
- github.com/Kludex/starlette/commit/69ed26a85956ef4bd0161807eb27abf49be7cd3c (opens in a new tab)
- github.com/Kludex/starlette (opens in a new tab)
- github.com/Kludex/starlette/releases/tag/0.49.1 (opens in a new tab)