Skip to main content
CVE-2024-2961VulnerabilityPublished Updated

Glibc: The iconv() function

Affects glibcSource GCVE Database

0
Compare
Authoritative record:CVE-2024-2961· High 7.3

Public exploit available (Metasploit) · 88% EPSS · CVSS 7.3 High : upgrade to 2.39 as a priority.

Data as of 5 Nov 2026, 09:07 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.3
EPSS
88.3% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.39
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    1 Metasploit module

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade glibc to 2.39.

Affected software

ProductAffectedFixed in
Homebrewglibcpkg:brew/glibcOther threatsAffected
  • <2.39
Fixed in
  • 2.39

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to GNU C Library version 2.39 or later, where this vulnerability is fixed. Since a patch is available, applying the official fix is the recommended mitigation. No additional vendor advisory indicates alternative mitigations or no-action requirements.

Description

The iconv() function in GNU C Library (glibc) versions older than 2.39 may overflow the output buffer by up to 4 bytes when converting strings to the ISO-2022-CN-EXT character set. This buffer overflow can potentially crash applications or overwrite adjacent memory variables. The vulnerability is identified as CVE-2024-2961 and has a high severity rating. A fix is available in glibc version 2.39.

References

Community reviews

Loading reviews…