CVE-2026-81727: NLTK · Downloader.download follows hardlinks and overwrites outside-root files
Affects gptlineSource GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 1.0.8_23 soon.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.0.8_23
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade gptline to 1.0.8_23.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewgptlinepkg:brew/gptlineOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in NLTK version 3.10.3 that treats pre-existing hardlinks as unsafe during extraction and verifies that write paths remain within the intended install tree at the inode level. Users should upgrade to version 3.10.3 or later to remediate this issue. Until patched, ensure that the downloader root directory is not writable by untrusted users to prevent exploitation.
Description
NLTK's downloader component has a filesystem containment bypass vulnerability where it fails to treat pre-existing hardlinks inside the install tree as unsafe. This allows an attacker with write access to the downloader root on the same filesystem to overwrite files outside the intended installation directory by exploiting hardlinks. The issue affects versions 3.9.4 and 3.10.0-rc2 and is fixed in version 3.10.3.
References
- github.com/nltk/nltk/security/advisories/GHSA-f794-5jv7-7672 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-81727 (opens in a new tab)
- github.com/nltk/nltk/pull/3797 (opens in a new tab)
- github.com/nltk/nltk/commit/9e6d5f05902b9aaa1221a0a565448d17a9c9b3e8 (opens in a new tab)
- github.com/nltk/nltk (opens in a new tab)
- github.com/nltk/nltk/releases/tag/v3.10.3 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/nltk/PYSEC-2026-3741.yaml (opens in a new tab)
- vulncheck.com/advisories/nltk-before-3.10.3-hardlink-file-overwrite-via-downloader (opens in a new tab)