CVE-2026-81725: NLTK · Pl196xCorpusReader has quadratic ReDoS on malformed TEI blocks
Affects gptlineSource GCVE Database
Not known to be exploited · CVSS 6.3 Medium : upgrade to 1.0.8_23 when convenient.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.0.8_23
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade gptline to 1.0.8_23.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewgptlinepkg:brew/gptlineOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available but not yet released. The vendor recommends replacing the lazy regex parser with a linear parser or bounded tokenizer and adding regression tests to ensure near-linear parsing time on malformed inputs. If you cannot patch yet, users should avoid processing untrusted or attacker-controlled corpus files with Pl196xCorpusReader to mitigate risk.
Description
The Pl196xCorpusReader component in the gptline product has a Regular Expression Denial of Service (ReDoS) vulnerability (CVE-2026-81725) caused by quadratic CPU growth when parsing malformed TEI blocks with many unmatched opening tags. This affects versions from 1.0.8 up to but not including 1.0.8_23. The vulnerability arises from lazy regex patterns that repeatedly rescan attacker-controlled text, leading to excessive CPU consumption and potential parser thread stalling.
References
- github.com/nltk/nltk/security/advisories/GHSA-8mpw-7fpc-4gqj (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-81725 (opens in a new tab)
- github.com/nltk/nltk/commit/7808692d451b962711005d954859bb83aabcf8fa (opens in a new tab)
- github.com/nltk/nltk (opens in a new tab)
- github.com/nltk/nltk/releases/tag/v3.10.3 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/nltk/PYSEC-2026-3752.yaml (opens in a new tab)
- vulncheck.com/advisories/nltk-before-3.10.3-regular-expression-denial-of-service-via-pl196xcorpusreader (opens in a new tab)