CVE-2026-42561: Gptme · python-multipart has Denial of Service via unbounded multipart part headers
Affects gptmeSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 0.31.0_8 soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.31.0_8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade gptme to 0.31.0_8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewgptmepkg:brew/gptmeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade python-multipart to version 0.31.0_8 or later to apply the official fix. If immediate upgrade is not possible, mitigate exposure by enforcing request body size limits at the server, proxy, or framework level, although this is only a partial mitigation and does not address the underlying parser limits issue.
Description
python-multipart versions from 0.28.0 up to but not including 0.31.0_8 contain a denial of service vulnerability in multipart part header parsing. The MultipartParser did not limit the number or size of part headers, allowing attackers to cause excessive CPU usage by sending requests with many repeated headers or very large header values. This can lead to worker or event-loop delays in ASGI applications using frameworks like Starlette or FastAPI. The issue is fixed in version 0.31.0_8.