schemathesis · GraphQL-core: Denial of service via quadratic complexity in the OverlappingFieldsCanBeMerged validation rule
Affects schemathesisSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 4.26.0 soon.
Data as of 30 Oct 2026, 07:16 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.26.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade schemathesis to 4.26.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewschemathesispkg:brew/schemathesisOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade GraphQL-core to version 3.2.12 or later, or 3.3.0rc1 or later, where a comparison budget limits validation cost and aborts excessive queries. If upgrading is not possible, implement request body-size limits on the decompressed request to reject oversized documents before validation. Do not remove the OverlappingFieldsCanBeMerged rule, as it is required for specification compliance. The default comparison budget is high enough to allow legitimate queries while preventing pathological ones.
Description
A denial of service vulnerability exists in GraphQL-core's OverlappingFieldsCanBeMerged validation rule, which can be exploited by a crafted query causing quadratic to worst-case O(n²·m²) validation time. This can exhaust CPU resources for minutes on a single core during validation, without requiring authentication or exposing data. The issue affects default settings of GraphQL-core based servers. The vulnerability is fixed in versions 3.2.12 and 3.3.0rc1 by enforcing a comparison budget that aborts validation on excessive complexity.
References
- github.com/graphql-python/graphql-core/security/advisories/GHSA-vj8h-fx38-h3vc (opens in a new tab)
- github.com/graphql-python/graphql-core/commit/150e59814d97d12140be005a558c93188ef89198 (opens in a new tab)
- github.com/graphql-python/graphql-core/commit/29c2753a7ee30a96a4109e7c6add1a2dae0497d7 (opens in a new tab)
- github.com/graphql-python/graphql-core (opens in a new tab)
- github.com/graphql-python/graphql-core/releases/tag/v3.2.12 (opens in a new tab)
- github.com/graphql-python/graphql-core/releases/tag/v3.3.0rc1 (opens in a new tab)