Skip to main content
VulnerabilityPublished Updated

CVE-2024-47539: Gst plugins good0.10 · An out-of-bounds write vulnerability was identified in the convert_to_s334_1a

Affects gst-plugins-good0.10Source GCVE Database

0
Compare
Authoritative record:CVE-2024-47539· High 8.6

Not known to be exploited · CVSS 8.6 High · fixed in 1.16.3-0ubuntu1.3 : patch gst-plugins-good0.10 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.08.6
EPSS
1.3% chance of exploitation in 30 days – higher than 71% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.16.3-0ubuntu1.3, 1.20.3-0ubuntu1.3, 1.24.2-1ubuntu1.1
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the Ubuntu gst-plugins-good1.0 to 1.16.3-0ubuntu1.3 (package) or 1.20.3-0ubuntu1.3 (package) or 1.24.2-1ubuntu1.1 (package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSgst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=nobleOther threatsAffected
  • <1.24.2-1ubuntu1.1
Fixed in
  • 1.24.2-1ubuntu1.1
Ubuntu 22.04 LTSgst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=jammyOther threatsAffected
  • <1.20.3-0ubuntu1.3
Fixed in
  • 1.20.3-0ubuntu1.3
Ubuntu 20.04 LTSgst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=focalOther threatsAffected
  • <1.16.3-0ubuntu1.3
Fixed in
  • 1.16.3-0ubuntu1.3
Ubuntu 16.04 LTSgst-plugins-good0.10pkg:deb/ubuntu/gst-plugins-good0.10?arch=source&distro=xenialOther threatsAffected
  • 0.10.31-3+nmu4ubuntu2.16.04.1 – 0.10.31-3+nmu4ubuntu2~gcc5.1
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and users should update to the patched package versions: 1.16.3-0ubuntu1.3, 1.20.3-0ubuntu1.3, or 1.24.2-1ubuntu1.1 depending on their Ubuntu release. The vendor advisory recommends applying standard system updates to receive these fixes. No additional mitigation steps are required beyond applying the official patches.

Description

An out-of-bounds write vulnerability exists in the convert_to_s334_1a function of the gst-plugins-good0.10 component of GStreamer. This flaw occurs due to a mismatch between allocated memory size and loop bounds, allowing up to 3 bytes to be overwritten beyond the allocated storage. Exploitation could lead to denial of service or arbitrary code execution. The vulnerability is fixed in versions 1.16.3-0ubuntu1.3, 1.20.3-0ubuntu1.3, and 1.24.2-1ubuntu1.1. Affected Ubuntu releases include 16.04 LTS, 20.04 LTS, 22.04 LTS, and 24.04 LTS. The CVSS score is 9.8, indicating critical severity.

References

Community reviews

Loading reviews…