Skip to main content
VulnerabilityPublished Updated

CVE-2026-53705: Gst plugins good1.0 · A flaw was found in GStreamer's WavPack audio decoder in gst-plugins-good

Affects gst-plugins-good1.0Source GCVE Database

0
Authoritative record:CVE-2026-53705· High 7.6

Not known to be exploited · CVSS 7.6 High · fixed in 1.20.3-0ubuntu1.7 : patch gst-plugins-good1.0 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.20.3-0ubuntu1.7, 1.24.2-1ubuntu1.5, 1.28.2-2ubuntu0.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu gst-plugins-good1.0 to 1.20.3-0ubuntu1.7 (package) or 1.24.2-1ubuntu1.5 (package) or 1.28.2-2ubuntu0.1 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSgst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=resoluteOther threatsAffected
  • <1.28.2-2ubuntu0.1
Fixed in
  • 1.28.2-2ubuntu0.1
Ubuntu 25.10gst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=questingOther threatsAffected
  • 1.26.0-1ubuntu2 – 1.26.5-1ubuntu2.3
9 affected builds
Fixed in–
Ubuntu 24.04 LTSgst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=nobleOther threatsAffected
  • <1.24.2-1ubuntu1.5
Fixed in
  • 1.24.2-1ubuntu1.5
Ubuntu 22.04 LTSgst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=jammyOther threatsAffected
  • <1.20.3-0ubuntu1.7
Fixed in
  • 1.20.3-0ubuntu1.7
Ubuntu Pro 20.04 LTSgst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=esm-infra/focalOther threatsAffected
  • 1.16.1-1ubuntu1 – 1.16.3-0ubuntu1.3+esm4
12 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSgst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 1.12.3-1ubuntu1 – 1.14.5-0ubuntu1~18.04.3+esm4
14 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A flaw was found in GStreamer's WavPack audio decoder in gst-plugins-good. When processing a specially crafted WavPack file, an integer overflow in the buffer size calculation (4 * block_samples * channels) in gst_wavpack_dec_handle_frame() causes a very small heap allocation. The WavPack library then writes decoded audio samples far beyond the allocated buffer, resulting in heap memory corruption. This affects both 32-bit and 64-bit systems since the arithmetic is performed in 32-bit integers before promotion to the allocation size type. A remote attacker could use this flaw to crash an application or potentially execute arbitrary code by convincing a user to open a malicious WavPack audio file.

References

Community reviews

Loading reviews…