Skip to main content
VulnerabilityPublished

CVE-2026-48979: PHP Standard Library · HTTP/2 server-side missing content-length validation enables request smuggling

Affects php-standard-library/h2Source GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 6.1.2 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.1.2, 6.2.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade php-standard-library/h2 and php-standard-library/php-standard-library to 6.1.2; php-standard-library/h2 and php-standard-library/php-standard-library to 6.2.1.

Affected software

ProductAffectedFixed in
Packagistphp-standard-library/h2Affected
  • >=6.1.0 <6.1.2
Fixed in
  • 6.1.2
Packagistphp-standard-library/h2Affected
  • >=6.2.0 <6.2.1
Fixed in
  • 6.2.1
Packagistphp-standard-library/php-standard-libraryAffected
  • >=6.1.0 <6.1.2
Fixed in
  • 6.1.2
Packagistphp-standard-library/php-standard-libraryAffected
  • >=6.2.0 <6.2.1
Fixed in
  • 6.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in PHP Standard Library versions 6.1.2 and 6.2.1. These versions implement proper parsing and validation of the content-length header on incoming HEADERS frames, track cumulative DATA frame payload length per stream, and throw exceptions on mismatches or overflow. Applications using Psl\H2\ServerConnection directly to accept untrusted client traffic should upgrade to these fixed versions. No protocol-layer workarounds exist.

Description

The PHP Standard Library's HTTP/2 server implementation (Psl\H2\ServerConnection) lacks validation that the total bytes received in DATA frames match the content-length header declared in the HEADERS frame, violating RFC 9113 §8.1.1. This allows a malicious client to send more or fewer DATA bytes than declared, potentially leading to request smuggling or incorrect application behavior. The vulnerability affects only consumers directly using Psl\H2\ServerConnection to accept untrusted client traffic; higher-level PSL HTTP server APIs are not affected. Fixes are available in versions 6.1.2 and 6.2.1. No protocol-layer workarounds exist, so upgrading is necessary for affected users.

References

Community reviews

Loading reviews…