CVE-2026-110354: (HAProxy 3 before 3.4.6 allows a remote unauthenticated attacker to cau ...)
Affects haproxySource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 3.4.6 : patch haproxy soon.
Data as of 27 Oct 2026, 08:12 UTC
- Patch
- Available – fixed in 3.4.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10haproxypkg:deb/ubuntu/haproxy?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTShaproxypkg:deb/ubuntu/haproxy?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTShaproxypkg:deb/ubuntu/haproxy?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTShaproxypkg:deb/ubuntu/haproxy?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTShaproxypkg:deb/ubuntu/haproxy?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTShaproxypkg:deb/ubuntu/haproxy?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in HAProxy version 3.4.6. Users should upgrade to version 3.4.6 or later to remediate this vulnerability. No other mitigation guidance is provided.
Description
HAProxy versions before 3.4.6 contain a vulnerability that allows a remote unauthenticated attacker to cause a denial of service. This vulnerability does not impact confidentiality or integrity but can disrupt availability by causing service outages.