Skip to main content
VulnerabilityPublished Updated

CVE-2026-110353: (HAProxy 3.2 before 3.4.6 allows a remote unauthenticated attacker to c ...)

Affects haproxySource GCVE Database

0
Authoritative record:CVE-2026-110353· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 3.4.6 : patch haproxy soon.

Data as of 27 Oct 2026, 08:12 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.4.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10haproxypkg:deb/ubuntu/haproxy?arch=source&distro=stonkingOther threatsAffected
  • 3.2.9-1ubuntu2 – 3.4.2-1ubuntu4
6 affected builds
Fixed in–
Ubuntu 26.04 LTShaproxypkg:deb/ubuntu/haproxy?arch=source&distro=resoluteOther threatsAffected
  • 3.0.10-1ubuntu3 – 3.2.25-0ubuntu0.26.04.1
6 affected builds
Fixed in–
Ubuntu 24.04 LTShaproxypkg:deb/ubuntu/haproxy?arch=source&distro=nobleOther threatsAffected
  • 2.6.15-1ubuntu2 – 2.8.30-0ubuntu0.24.04.1
13 affected builds
Fixed in–
Ubuntu 22.04 LTShaproxypkg:deb/ubuntu/haproxy?arch=source&distro=jammyOther threatsAffected
  • 2.2.9-2ubuntu2 – 2.4.30-0ubuntu0.22.04.2
21 affected builds
Fixed in–
Ubuntu 20.04 LTShaproxypkg:deb/ubuntu/haproxy?arch=source&distro=focalOther threatsAffected
  • 2.0.5-1 – 2.0.33-0ubuntu0.1
20 affected builds
Fixed in–
Ubuntu Pro 18.04 LTShaproxypkg:deb/ubuntu/haproxy?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 1.7.9-1ubuntu1 – 1.8.8-1ubuntu0.13+esm3
18 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade HAProxy to version 3.4.6 or later where this vulnerability is fixed. Since this is a high severity denial of service vulnerability, applying the official fix is recommended to prevent service disruption.

Description

HAProxy versions 3.2 before 3.4.6 contain a vulnerability that allows a remote unauthenticated attacker to cause a denial of service (DoS) condition. This flaw does not impact confidentiality or integrity but can disrupt availability by crashing or otherwise incapacitating the service.

References

Community reviews

Loading reviews…