Skip to main content
VulnerabilityPublished

CVE-2026-92750: Harness through 3.3.0 omits access control validation in the infrastructure provider read endpoint, allowing authenticated users to retrieve

Affects harnessSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.3.1 when convenient.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade harness/harness to 3.3.1.

Affected software

ProductAffectedFixed in
GitHubharness/harnesspkg:github/harness/harnessOther threatsAffected
  • <3.3.1
Fixed in
  • 3.3.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict authenticated user access to trusted parties only and monitor for suspicious use of the GET /api/v1/infraproviders endpoint with arbitrary space identifiers.

Description

A vulnerability in Harness through version 3.3.0 allows authenticated users to bypass access control on the infrastructure provider read endpoint. This flaw enables retrieval of provider configurations from spaces the user does not belong to. Sensitive metadata exposed includes Docker endpoints, TLS certificate paths, and cloud project identifiers. The vulnerability has a CVSS score of 6.5, indicating a high severity impact on confidentiality without affecting integrity or availability.

References

Community reviews

Loading reviews…