CVE-2026-19023: hdf5 security update
Affects hdf5Source GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 6.8 Medium : upgrade to 1.14.5-8.oe2403sp4 when convenient.
Data as of 29 Oct 2026, 10:49 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.14.5-8.oe2403sp4
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 5 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade hdf5 to 1.14.5-8.oe2403sp4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP4hdf5pkg:rpm/openEuler/hdf5&distro=openEuler-24.03-LTS-SP4Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update addressing these vulnerabilities is available in HDF5 version 1.14.5-8.oe2403sp4. Users and administrators should upgrade to this fixed version to remediate the issues. No additional mitigation actions are specified or required beyond applying the official patch.
Description
Multiple denial of service vulnerabilities exist in HDF5 before version 2.3.0, including untrusted pointer dereference, NULL pointer dereference, out-of-bounds heap read, and size underflow issues. These flaws affect various components such as the h5dump tool, fill value handling, N-Bit filter processing, and Fletcher32 checksum calculation. The vulnerabilities can be triggered by crafted HDF5 files and may cause application crashes or memory disclosure in constrained cases. A security update fixing these issues is available in version 1.14.5-8.oe2403sp4.
References
- openeuler.org/zh/security/security-bulletins/detail/?id=openEuler-SA-2026-4606 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-19023 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-19024 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-19026 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-19027 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-19028 (opens in a new tab)