Skip to main content
VulnerabilityPublished

CVE-2026-19023: hdf5 security update

Affects hdf5Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-19023· Medium 6.8

Not known to be exploited · CVSS 6.8 Medium : upgrade to 1.14.5-8.oe2403sp3 when convenient.

Data as of 29 Oct 2026, 10:49 UTC

CVSS 4.0 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.14.5-8.oe2403sp3
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade hdf5 to 1.14.5-8.oe2403sp3.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP3hdf5pkg:rpm/openEuler/hdf5&distro=openEuler-24.03-LTS-SP3Other threatsAffected
  • <1.14.5-8.oe2403sp3
Fixed in
  • 1.14.5-8.oe2403sp3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security fix is available in HDF5 version 1.14.5-8.oe2403sp3 and later. Users and administrators should upgrade to these fixed versions to remediate the vulnerabilities. No additional mitigation actions are specified or required beyond applying the official patch.

Description

Multiple security vulnerabilities have been identified in HDF5 before version 2.3.0, including untrusted pointer dereference, NULL pointer dereference, out-of-bounds heap read, and size_t underflow. These flaws can lead to denial of service or memory disclosure when processing crafted HDF5 files with specific characteristics. The issues affect tools such as h5dump, h5ls, and h5repack. A high severity CVSS 8.2 score reflects the significant impact of these vulnerabilities. Fixed versions are available starting from 1.14.5-8.oe2403sp3.

References

Community reviews

Loading reviews…