Skip to main content
VulnerabilityPublished Updated

CVE-2026-91767: php_openssl_matches_wildcard_name · Heap-buffer-overflow

Affects phpSource GCVE Database

0
Compare
Authoritative record:CVE-2026-91767· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium · fixed in 8.5.11 : update php when convenient.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.5.11, 8.4.26, 8.3.35 +1
CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade php to 8.5.11, 8.4.26, 8.3.35 or 8.2.34.

Affected software

ProductAffectedFixed in
Bitnamiphppkg:bitnami/phpOther threatsAffected
  • >=8.2.0 <8.2.34
  • >=8.3.0 <8.3.35
  • >=8.4.0 <8.4.26
  • >=8.5.0 <8.5.11
Fixed in
  • 8.2.34
  • 8.3.35
  • 8.4.26
  • 8.5.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should upgrade to PHP versions 8.2.34, 8.3.35, 8.4.26, or 8.5.11 or later to remediate this vulnerability. Since verify_peer_name is enabled by default, no configuration changes are required to mitigate the issue other than applying the official fixes.

Description

A heap-buffer-overflow vulnerability exists in the PHP function php_openssl_matches_wildcard_name() when processing TLS server certificates with wildcard names longer than the hostname being verified. This flaw allows a malicious server to cause the PHP client to read memory beyond the allocated heap buffer. The vulnerability is reachable by default because peer name verification is enabled by default in PHP client streams. It affects multiple PHP versions prior to fixed releases.

References

Community reviews

Loading reviews…