CVE-2026-119196: Hermes agent · pyasn1 has quadratic CPU consumption in constructed BIT STRING decoding
Affects hermes-agentSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.5 High · fixed in 2026.4.30 : patch hermes-agent soon.
Data as of 31 Oct 2026, 18:23 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 2026.4.30
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewhermes-agentpkg:brew/hermes-agentOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in pyasn1 version 2026.4.30 that fixes this vulnerability. Users should upgrade to this version or later to remediate the issue. There are no vendor advisories indicating that no action is required or that the issue is already mitigated. Until patched, applications should consider restricting or validating ASN.1 input sizes and fragment counts if possible to reduce risk.
Description
CVE-2026-119196 is a high-severity vulnerability in pyasn1 up to version 0.6.4 used by hermes-agent, where decoding constructed BIT STRING values with many fragments causes quadratic CPU consumption. This can lead to CPU exhaustion and denial of service when processing attacker-controlled ASN.1 data. The issue affects BER and CER decoders and certain schema-driven DER decoding paths. A fix is available in version 2026.4.30.
References
- github.com/pyasn1/pyasn1/security/advisories/GHSA-2qm8-x737-gmw5 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-119196 (opens in a new tab)
- github.com/pyasn1/pyasn1/pull/132 (opens in a new tab)
- github.com/pyasn1/pyasn1/commit/73ba7b043cc7e92cb37f16f2c955bff93b0e6f6c (opens in a new tab)
- github.com/pyasn1/pyasn1 (opens in a new tab)
- github.com/pyasn1/pyasn1/releases/tag/v0.6.5 (opens in a new tab)