CVE-2026-48524: Hermes agent · PyJWKClient unbounded JWKS endpoint requests via attacker-controlled kid values (DoS)
Affects hermes-agentSource GCVE Database
Not known to be exploited · CVSS 3.7 Low : upgrade to 2026.7.1 when convenient.
Data as of 30 Oct 2026, 09:02 UTC
- Patch
- Available – fixed in 2026.7.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 28 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade hermes-agent to 2026.7.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewhermes-agentpkg:brew/hermes-agentOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Hermes agent version 2026.7.1 that addresses this issue by adding a refresh cooldown to limit JWKS endpoint requests and changing cache handling to prevent clearing valid data on network errors. Users should upgrade to version 2026.7.1 or later to remediate this vulnerability. No additional mitigation actions are required beyond applying the official fix.
Description
CVE-2026-48524 is a denial-of-service vulnerability in Hermes agent's PyJWKClient component. The flaw causes the client to issue a fresh HTTP request to the JWKS endpoint for every JWT with an unknown key ID (kid) without rate limiting. This can be exploited by an attacker sending tokens with attacker-controlled kid values, triggering unlimited outbound requests and causing network latency and potential cascading failures in authentication. The vulnerability affects versions from 2026.4.30 up to but not including 2026.7.1. A fix is available in version 2026.7.1.
References
- github.com/jpadilla/pyjwt/security/advisories/GHSA-fhv5-28vv-h8m8 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-48524 (opens in a new tab)
- github.com/github/advisory-database/pull/8522 (opens in a new tab)
- github.com/jpadilla/pyjwt (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/pyjwt/PYSEC-2026-177.yaml (opens in a new tab)