Skip to main content
CVE-2026-123603VulnerabilityPublished

hickory-proto and hickory-resolver 0.26.0 before 0.26.2, hickory-server 0.25.0-alpha.1 before 0.26.2, and

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123603· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 0.26.2 when convenient.

Data as of 8 Nov 2026, 06:21 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.9
CNA (VulnCheck)CVSS 3.16.5
Patch
Available – fixed in 0.26.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade hickory-dns to 0.26.2.

Affected software

ProductAffectedFixed in
hickory-dnshickory-dnsAffected
  • >=0.25.0-alpha.3 <=0.26.0-alpha.1
Fixed in–
hickory-dnshickory-dnsAffected
  • >=0.26.0 <0.26.2
Fixed in
  • 0.26.2
hickory-dnshickory-dnsAffected
  • >=0.25.0-alpha.1 <0.26.2
Fixed in
  • 0.26.2
crates.iohickory-dnspkg:cargo/hickory-dnsOther threatsAffected
  • >=0.25.0-alpha.3 <=0.26.0-alpha.1
  • >=0.26.0 <0.26.2
  • >=0.25.0-alpha.1 <0.26.2
Fixed in
  • 0.26.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade affected Hickory components to version 0.26.2 or later, where this issue is fixed. No other mitigation or temporary workaround is indicated. Since this is a client and server library vulnerability, patching the affected software versions is the recommended remediation.

Description

Multiple Hickory components prior to version 0.26.2 fail to properly canonicalize IPv4-mapped IPv6 addresses when enforcing deny_answers, deny_server, or AccessControlSet rules. This flaw allows attackers to bypass answer filtering, cause queries to denied nameservers, or access Hickory server deployments on dual-stack IPv6 sockets from clients that should be denied.

References

Community reviews

Loading reviews…