CVE-2026-84382: HTTPX2 · Streaming response decompression does not bound peak memory (decompression amplification)
Affects hermes-agentSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 0.22.2 soon.
Data as of 27 Oct 2026, 20:59 UTC
- Patch
- Available – fixed in 0.22.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade hermes-agent to 0.22.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewhermes-agentpkg:brew/hermes-agentOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade HTTPX2 to version 2.12.0 or later. The fixed versions decompress response bodies incrementally with bounded intermediate buffers, preventing excessive memory allocation during streaming decompression.
Description
HTTPX2 versions prior to 2.12.0 decompress streaming HTTP response bodies in a way that can cause excessive memory allocation. Specifically, each network read of up to 64 KiB is fully decompressed into a large intermediate buffer before yielding data, allowing a small compressed chunk to expand to tens of megabytes in memory. This can lead to memory pressure or out-of-memory termination when processing malicious compressed responses from untrusted servers. The issue affects applications that fetch resources from attacker-controlled servers without requiring authentication or user interaction. The vulnerability is fixed in HTTPX2 version 2.12.0 and later, which use incremental decompression with bounded buffers.
References
- github.com/pydantic/httpx2/security/advisories/GHSA-8xx6-hgc6-gc2m (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-84382 (opens in a new tab)
- github.com/pydantic/httpx2/pull/1126 (opens in a new tab)
- github.com/pydantic/httpx2/commit/4fd0c70a3f207c618b145934792f791bccfb39f8 (opens in a new tab)
- github.com/pydantic/httpx2 (opens in a new tab)
- github.com/pydantic/httpx2/releases/tag/v2.12.0 (opens in a new tab)