CVE-2026-84382: HTTPX2 · Streaming response decompression does not bound peak memory (decompression amplification)
Affects bump-my-versionSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 1.5.1_1 soon.
Data as of 26 Oct 2026, 17:56 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.5.1_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade bump-my-version to 1.5.1_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewbump-my-versionpkg:brew/bump-my-versionOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade HTTPX2 to version 1.5.1_1 or later. The patched versions implement incremental decompression with bounded intermediate buffers, preventing large transient memory allocations during streaming response decompression.
Description
HTTPX2 versions prior to 1.5.1_1 decompress streaming response bodies fully per network read, causing large intermediate memory allocations. This decompression amplification can lead to high memory usage or out-of-memory termination when processing malicious compressed responses from untrusted servers. The issue affects compressed responses using gzip, deflate, Brotli, or Zstandard encodings. The vulnerability is fixed in HTTPX2 version 1.5.1_1 by implementing incremental decompression with bounded buffers.
References
- github.com/pydantic/httpx2/security/advisories/GHSA-8xx6-hgc6-gc2m (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-84382 (opens in a new tab)
- github.com/pydantic/httpx2/pull/1126 (opens in a new tab)
- github.com/pydantic/httpx2/commit/4fd0c70a3f207c618b145934792f791bccfb39f8 (opens in a new tab)
- github.com/pydantic/httpx2 (opens in a new tab)
- github.com/pydantic/httpx2/releases/tag/v2.12.0 (opens in a new tab)