Skip to main content
VulnerabilityPublished

Hydra core: Hydra legacy target blacklist permits unsafe PyYAML loading

Affects hydra-coreSource GCVE Database

0

CVSS 7.8 High : upgrade to 1.3.8 soon.

Data as of 27 Oct 2026, 18:29 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.3.8, 1.4.0rc3
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

What to do

Upgrade hydra-core to 1.3.8; hydra-core to 1.4.0rc3.

Affected software

ProductAffectedFixed in
PyPIhydra-coreAffected
  • >=1.3.6 <1.3.8
Fixed in
  • 1.3.8
PyPIhydra-coreAffected
  • >=1.4.0.dev9 <1.4.0rc3
Fixed in
  • 1.4.0rc3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in hydra-core versions 1.3.8 and 1.4.0rc3 that blocks unsafe yaml targets except for safe_load and safe_dump functions. Users should upgrade to these fixed versions. As a workaround, do not pass untrusted configuration to instantiate() or call(), and for Hydra 1.4, use a narrow execution whitelist from trusted Python code. Do not allow untrusted configuration to select execution policies or opt out of checks.

Description

Hydra core versions 1.3.6 through 1.3.7 and 1.4.0.dev9 through 1.4.0rc2 have a vulnerability in the legacy target blacklist that omits unsafe PyYAML loading functions. This allows an attacker who controls the target and arguments passed to instantiate() to execute arbitrary Python code via a malicious YAML configuration. The issue affects legacy no-whitelist paths and is not a bypass of Hydra 1.4's execution whitelist. The vulnerability is fixed in versions 1.3.8 and 1.4.0rc3.

References

Community reviews

Loading reviews…