CVE-2026-56373: ImageMagick before 7.1.2-15 contains a use-after-free vulnerability in the PDB decoder that uses a
Affects imagemagickSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium · fixed in 8:6.7.7.10-6ubuntu3.13+esm25 : update imagemagick when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8:6.7.7.10-6ubuntu3.13+esm25, 8:6.8.9.9-7ubuntu5.16+esm24, 8:6.9.7.4+dfsg-16ubuntu6.15+esm16 +3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 10 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro 24.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro 22.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in
|
Ubuntu Pro 18.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in
|
Ubuntu Pro 16.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-infra-legacy/xenialOther threats | Affected
| Fixed in
|
Ubuntu Pro 14.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-infra-legacy/trustyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
ImageMagick before 7.1.2-15 contains a use-after-free vulnerability in the PDB decoder that uses a stale pointer when memory allocation fails. Attackers can trigger this vulnerability by processing malicious PDB files to cause crashes or write a single zero byte to freed memory.
References
- ubuntu.com/security/CVE-2026-56373 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-56373 (opens in a new tab)
- github.com/ImageMagick/ImageMagick/security/advisories/GHSA-3j4x-rwrx-xxj9 (opens in a new tab)
- vulncheck.com/advisories/imagemagick-use-after-free-write-in-pdb-decoder (opens in a new tab)
- ubuntu.com/security/notices/USN-8739-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8739-2 (opens in a new tab)