CVE-2026-56373: ImageMagick before 7.1.2-15 contains a use-after-free vulnerability in the PDB decoder that uses a
Affects ImageMagickSource GCVE Database
Not known to be exploited · CVSS 6.3 Medium : upgrade to 7.1.2-15 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 6.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 3.7 |
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.1.2-15
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade imagemagick/ImageMagick to 7.1.2-15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubimagemagick/ImageMagickpkg:github/imagemagick/ImageMagickOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in ImageMagick version 7.1.2-15. Users should upgrade to this version or later to remediate the vulnerability. Patch status is not explicitly confirmed in the input data, but the description states the issue exists before 7.1.2-15, implying the fix is included in 7.1.2-15. Verify with the vendor advisory for the latest remediation guidance.
Description
ImageMagick before 7.1.2-15 contains a use-after-free vulnerability in the PDB decoder that uses a stale pointer when memory allocation fails. Attackers can trigger this vulnerability by processing malicious PDB files to cause crashes or write a single zero byte to freed memory.