CVE-2026-56366: ImageMagick before 7.1.2-18 contains a memory leak vulnerability in the META reader when processing
Affects imagemagickSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium · fixed in 8:6.7.7.10-6ubuntu3.13+esm25 : update imagemagick when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8:6.7.7.10-6ubuntu3.13+esm25, 8:6.8.9.9-7ubuntu5.16+esm24, 8:6.9.7.4+dfsg-16ubuntu6.15+esm16 +3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 10 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro 24.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro 22.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in
|
Ubuntu Pro 18.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in
|
Ubuntu Pro 16.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-infra-legacy/xenialOther threats | Affected
| Fixed in
|
Ubuntu Pro 14.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-infra-legacy/trustyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
ImageMagick before 7.1.2-18 contains a memory leak vulnerability in the META reader when processing APP1JPEG input paths. Attackers can trigger this memory leak by providing specially crafted APP1JPEG image files, causing denial of service through resource exhaustion.
References
- ubuntu.com/security/CVE-2026-56366 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-56366 (opens in a new tab)
- github.com/ImageMagick/ImageMagick/security/advisories/GHSA-9r56-3gjq-hqf7 (opens in a new tab)
- vulncheck.com/advisories/imagemagick-memory-leak-in-meta-reader-app1jpeg-error-path (opens in a new tab)
- ubuntu.com/security/notices/USN-8739-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8739-2 (opens in a new tab)