Skip to main content
VulnerabilityPublished

CVE-2026-56374: ImageMagick before 7.1.2-19 contains a heap buffer overflow vulnerability in the FTXT encoder due to

Affects imagemagickSource GCVE Database

0

Not known to be exploited · CVSS 7.1 High · fixed in 7.1.2 : patch imagemagick soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.1.2
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSimagemagickpkg:deb/ubuntu/imagemagick@8:7.1.2.18+dfsg1-1?arch=source&distro=resoluteOther threatsAffected
  • 8:7.1.2.3+dfsg1-1 – 8:7.1.2.18+dfsg1-1
7 affected builds
Fixed in–
Ubuntu 25.10imagemagickpkg:deb/ubuntu/imagemagick@8:7.1.2.3+dfsg1-1ubuntu0.1?arch=source&distro=questingOther threatsAffected
  • 8:7.1.1.43+dfsg1-1 – 8:7.1.2.3+dfsg1-1ubuntu0.1
5 affected builds
Fixed in–
Ubuntu Pro 24.04 LTSimagemagickpkg:deb/ubuntu/imagemagick@8:6.9.12.98+dfsg1-5.2ubuntu0.1~esm10?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 8:6.9.11.60+dfsg-1.6ubuntu1 – 8:6.9.12.98+dfsg1-5.2ubuntu0.1~esm10
14 affected builds
Fixed in–
Ubuntu Pro 22.04 LTSimagemagickpkg:deb/ubuntu/imagemagick@8:6.9.11.60+dfsg-1.3ubuntu0.22.04.5+esm11?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 8:6.9.11.60+dfsg-1.3 – 8:6.9.11.60+dfsg-1ubuntu1
24 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSimagemagickpkg:deb/ubuntu/imagemagick@8:6.9.10.23+dfsg-2.1ubuntu11.11+esm11?arch=source&distro=esm-apps/focalOther threatsAffected
  • 8:6.9.10.23+dfsg-2.1ubuntu3 – 8:6.9.10.23+dfsg-2.1ubuntu11.11+esm11
31 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSimagemagickpkg:deb/ubuntu/imagemagick@8:6.9.7.4+dfsg-16ubuntu6.15+esm13?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 8:6.9.7.4+dfsg-16ubuntu2 – 8:6.9.7.4+dfsg-16ubuntu6.15+esm13
29 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in ImageMagick version 7.1.2-19 and later. Users should upgrade to this version or later to remediate the vulnerability.

Description

ImageMagick versions before 7.1.2-19 contain a heap buffer overflow vulnerability in the FTXT encoder due to missing boundary checks when parsing ftxt:format. This vulnerability allows remote attackers to cause out-of-bounds reads by crafting malicious FTXT image files, potentially leading to denial of service or information disclosure.

References

Community reviews

Loading reviews…