CVE-2026-61858: ImageMagick before 7.1.2-26 contains a policy bypass vulnerability in the APNG encoder and external
Affects ImageMagickSource GCVE Database
Not known to be exploited · CVSS 4.8 Medium : upgrade to 7.1.2-26 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 4.8 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 3.3 |
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.1.2-26
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 11 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade imagemagick/ImageMagick to 7.1.2-26.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubimagemagick/ImageMagickpkg:github/imagemagick/ImageMagickOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict access to ImageMagick usage to trusted users and environments.
Description
ImageMagick before 7.1.2-26 contains a policy bypass vulnerability in the APNG encoder and external delegates due to missing validation checks. Attackers can write files to disallowed paths by bypassing configured policy restrictions through the APNG encoding process.