CVE-2026-106577: ImageMagick is free and open-source software used for editing and manipulating digital images
Affects imagemagickSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium · fixed in 7.1.2 : update imagemagick when convenient.
Data as of 27 Oct 2026, 08:14 UTC
- Patch
- Available – fixed in 7.1.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro 26.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/resoluteOther threats | Affected
| Fixed in– |
Ubuntu Pro 24.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu Pro 22.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in– |
Ubuntu Pro 16.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-infra-legacy/xenialOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade ImageMagick to version 7.1.2-31 or later, or 6.9.13-56 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated by the vendor advisory.
Description
ImageMagick versions prior to 7.1.2-31 and 6.9.13-56 contain a vulnerability where unescaped or untrimmed values can lead to code injection in output generated by PostScript coders. This vulnerability has been fixed in versions 7.1.2-31 and 6.9.13-56. The CVSS 3.1 score is 6.5, indicating a medium severity issue.
References
- ubuntu.com/security/CVE-2026-106577 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-106577 (opens in a new tab)
- github.com/ImageMagick/ImageMagick/security/advisories/GHSA-5rg6-j44q-q892 (opens in a new tab)
- github.com/ImageMagick/ImageMagick/commit/2ba2edfd04a1ab3d45af4a0dc1e640dde7020192 (opens in a new tab)
- github.com/ImageMagick/ImageMagick/commit/78378cd623468760bee82a5930cb3011725916f8 (opens in a new tab)
- github.com/ImageMagick/ImageMagick/releases/tag/7.1.2-31 (opens in a new tab)
- github.com/ImageMagick/ImageMagick6/commit/879489740daa44dd72e9405b26c845e8aa3d2f53 (opens in a new tab)
- github.com/ImageMagick/ImageMagick6/commit/d5750d7309ef5a8cd561430d932a183e4168f484 (opens in a new tab)
- github.com/ImageMagick/ImageMagick6/releases/tag/6.9.13-56 (opens in a new tab)