Skip to main content
VulnerabilityPublished

CVE-2026-119124: ImageMagick security update

Affects ImageMagickSource GCVE Database

0
Compare
Authoritative record:CVE-2026-119124· Medium 4.8

Not known to be exploited · CVSS 4.8 Medium : upgrade to 7.1.2.35-1.oe2403sp3 when convenient.

Data as of 4 Nov 2026, 17:00 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.04.8
CNA (VulnCheck)CVSS 3.13.3
Patch
Available – fixed in 7.1.2.35-1.oe2403sp3
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade ImageMagick to 7.1.2.35-1.oe2403sp3.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP3ImageMagickpkg:rpm/openEuler/ImageMagick&distro=openEuler-24.03-LTS-SP3Other threatsAffected
  • <7.1.2.35-1.oe2403sp3
Fixed in
  • 7.1.2.35-1.oe2403sp3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade ImageMagick to version 7.1.2.35-1.oe2403sp3 or later, where this heap-based buffer overflow vulnerability is fixed. Applying this official patch fully mitigates the issue.

Description

ImageMagick before version 7.1.2.35-1.oe2403sp3 contains a heap-based buffer overflow vulnerability in its -morph image processing feature. This flaw allows an attacker to supply a crafted image that causes writes beyond the bounds of a heap buffer, potentially corrupting memory and crashing the application. The issue has been assigned CVE-2026-119124 and has a medium severity rating with a CVSS score of 4.8. A fix is available in version 7.1.2.35-1.oe2403sp3.

References

Community reviews

Loading reviews…