CVE-2026-119124: ImageMagick security update
Affects ImageMagickSource GCVE Database
Not known to be exploited · CVSS 4.8 Medium : upgrade to 7.1.2.35-1.oe2203sp4 when convenient.
Data as of 4 Nov 2026, 17:00 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 4.8 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 3.3 |
- Patch
- Available – fixed in 7.1.2.35-1.oe2203sp4
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade ImageMagick to 7.1.2.35-1.oe2203sp4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 22.03-LTS-SP4ImageMagickpkg:rpm/openEuler/ImageMagick&distro=openEuler-22.03-LTS-SP4Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and fixed in ImageMagick version 7.1.2-35-1.oe2203sp4. Users should upgrade to this version or later to remediate the vulnerability. No additional mitigation steps are indicated.
Description
ImageMagick before version 7.1.2-35-1.oe2203sp4 contains a heap-based buffer overflow vulnerability in its -morph image processing feature. This flaw allows crafted images to cause writes beyond the bounds of a heap buffer, potentially corrupting memory and crashing the application when processed with the -morph option.